RabbitMQ安装报错 erlang >= 19.3 is needed by rabbitmq-server-3.7.9-1.el7.noarch

原创 创建时间:2018-12-10 访问量:2876 赞:0 踩:0


错误如下:

warning: rabbitmq-server-3.7.9-1.el7.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 6026dfca: NOKEY
error: Failed dependencies:
erlang >= 19.3 is needed by rabbitmq-server-3.7.9-1.el7.noarch

出错以上错误主要是erlang语言版本不对,重新下载erlang语言的新版本:http://erlang.org/download/,并编译安装。erlang完成后使用erl命令能正进入。再使用以下命令安装:

sudo rpm -ih rabbitmq-server-3.7.9-1.el7.noarch.rpm --nodeps

安装完成后运行:

sudo rabbitmq-server

报错:

/usr/lib/rabbitmq/bin/rabbitmq-server: line 189: erl: command not found

找不到erl命令:

使用su将用户提升到root即可运行。


rabbitmq 3.7依赖包如下:

如果之前通过yum install erlang安装的话,要卸载相关的依赖包。如要安装依赖较多,可以写一个shell脚来卸载。

删除Shell脚本:

vi uninstall.sh

chmod +x uninstall.sh

lists=`rpm -qa | grep erlang`
for var in $lists;do
echo $var
sudo rpm -e --nodeps $var
done


如果不想进行以上步骤,也可以通过yum安装rabbitmq


评论
 我想说:
==已经到底了==
关注: 粉丝: 积分:
工联信息网
如有问题请致邮箱:need@glxxw2018.com(仅限本站无法查询到的资料);本站能够查询到的资料请关注“工联信息网”公众号,通过页面提供的资源码查询!
不良信息反馈及侵权投诉建议请致邮箱:accusation@glxxw2018.com